What are the system requirements for the website?

We support the latest two versions of the following browsers: Chrome, Edge, Safari, and Firefox.

In addition, you will need to have javascript enabled and a live internet connection.